US call issues
Incident Report for Infinity
Resolved
The carrier has informed us that the problem is resolved. We have verified stability with test calls and are continuing to monitor the situation.
Posted May 03, 2023 - 17:24 BST
Investigating
We are aware of some call issues reported to some US numbers and are investigating.
Posted May 02, 2023 - 21:39 BST
This incident affected: US Telecoms Carriers (US Carrier DL, US Carrier DW).