Call routing issues in US
Incident Report for Infinity
Resolved
We have closed it as all calls are flowing fine after a considerable amount of monitoring.
Posted Oct 19, 2021 - 21:11 BST
Update
Further ongoing monitoring on call quality issues across US.
Posted Oct 19, 2021 - 18:27 BST
Update
We are continuing to monitor for any further issues.
Posted Oct 19, 2021 - 18:08 BST
Monitoring
Call Routing issues identified and we have failed over to other providers. We are currently monitoring.

Update in 30 mins.
Posted Oct 19, 2021 - 18:30 BST