Legacy Looker Studio Connector Error

Incident Report for Infinity

Resolved

Our legacy connectors are confirmed as no longer supported in Google Data Studio. Reports built using legacy connectors will need to be updated to use the current connectors. Instructions for this can be found in https://campus.infinity.co/campus/s/article/Google-Data-Studio-Connectors

If you require assistance updating your Data Studio reports, please contact support@infinity.co or your Customer Success representative.
Posted Jun 05, 2026 - 14:41 BST

Investigating

We are currently investigating an issue affecting the Legacy Looker Studio Connector, which may prevent some customers from successfully loading or refreshing reports.

Customer impact:
Affected customers may experience errors loading data or exports showing an “unknown data source” when using the Legacy Looker Studio Connector. Other platform functionality is not impacted.

Our engineering teams are actively investigating the root cause and working to restore normal service as quickly as possible. All data remains safe and secure.

This status page will be updated as further information becomes available.
Posted Jun 05, 2026 - 13:46 BST
This incident affected: Third-Party Integrations (Other).