Smart Match FTP Upload Outage
Incident Report for Infinity
Resolved
This incident has now been resolved.
Posted Oct 25, 2021 - 21:42 BST
Investigating
We are currently investigating this issue.
Posted Oct 25, 2021 - 19:50 BST